読者です 読者をやめる 読者になる 読者になる

eclipse::x64版でPleiades(日本語化)しようとして最初からハマった

androidアプリをつついてみようと思い、自宅win7x32でEclipse+pleiadesを入れた。
http://www.techfirm.co.jp/lab/android/setting.html
Eclipseには憧れだけがあり、普段は「さくら(エディタ)ちゃんマジ天使」の体で生活。

スムーズにインストールが済んだので、会社のw7x64にも再度Eclipseを導入しようとしてみた。
http://d.hatena.ne.jp/penult/20091220/1261315355

Eclipse単体では問題無く起動したものの、pleiades入れた途端に起動できなくなる。

エラー:Cound not create the Java virtual machine

調べてみると、JDKへのパスをWindowsが認識していない事が原因との事。



[Cound not create the Java virtual machineエラー対処方法の表示]
http://sourceforge.jp/projects/qbrowserv2/docs/howtoavoidcouldnotcreatejvm/ja/2/howtoavoidcouldnotcreatejvm.txt

JDK1.5以下のjavaを使用しているために発生するエラーです。
(JDK1.6がインストールされていても、pathに含まれていない、pathにjdk1.5以下のパスが書いてあるなどの理由で同様のエラーが発生します)

1. JDK1.6がインストールされていて、pathにJDK1.6_HOME\binが含まれているかを確認します。コマンドウインドウを開いて単に
java -version
と入力してみてください。

java version "1.6.0_13"
Java(TM) SE Runtime Environment (build 1.6.0_13-b03)
Java HotSpot(TM) Client VM (build 11.3-b02, mixed mode, sharing)

というように1.6以上のバージョンが表示されれば準備OKです。
もし1.5以下ですと、起動時に「Could not create the Java Virtual Machine」となりエラーとなってしまいます。

対処法は

1.JDK1.6がインストールされていない場合、http://java.sun.comから、JDK1.6をダウンロード、インストール、java_home\binをPATH環境変数に含める作業を行ってから起動してみます。

2.JDK1.6がインストールされている場合
PATH環境変数の先頭にjdk1.6_home\binが来るように環境変数を編集します。
エクスプローラ→マイコンピュータ→右クリック→プロパティ→詳細設定タブ→環境変数ボタン
設定したら、適用ボタンを押します。


解決―